summaryrefslogtreecommitdiff
path: root/obsolete-buildroot/make
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2004-08-12 06:43:18 +0000
committerMike Baker <mbm@openwrt.org>2004-08-12 06:43:18 +0000
commitb8498ba4793c3a73af038ea99f25034e15f9a6b8 (patch)
tree22752a601529b6191cdb4ca51cd33cf419daf621 /obsolete-buildroot/make
parentab8c3f11f4efaff748c7940dc96d9c4fa91dab24 (diff)
downloadmtk-20170518-b8498ba4793c3a73af038ea99f25034e15f9a6b8.zip
mtk-20170518-b8498ba4793c3a73af038ea99f25034e15f9a6b8.tar.gz
mtk-20170518-b8498ba4793c3a73af038ea99f25034e15f9a6b8.tar.bz2
moved root.tar.gz to sources/openwrt/root
SVN-Revision: 135
Diffstat (limited to 'obsolete-buildroot/make')
-rw-r--r--obsolete-buildroot/make/openwrt.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/obsolete-buildroot/make/openwrt.mk b/obsolete-buildroot/make/openwrt.mk
index e839a0a..5867046 100644
--- a/obsolete-buildroot/make/openwrt.mk
+++ b/obsolete-buildroot/make/openwrt.mk
@@ -23,7 +23,7 @@
# Currently the dependencies are not all handled. But that's true of
# our buildroot in general, since it wasn't really set up for end users.
-OPENWRT_TARGETS:= openwrt-linux openwrt-kmodules.tar.bz2 \
+OPENWRT_TARGETS:= gcc3_3 openwrt-linux openwrt-kmodules.tar.bz2 \
openwrt-shared openwrt-mtd openwrt-nvram openwrt-wlconf \
bridge dnsmasq1 iptables wtools busybox \
openwrt-rootprep
@@ -34,8 +34,6 @@ openwrt-base: $(OPENWRT_TARGETS)
######################################################################
-ifneq ($(filter $(TARGETS),openwrt-base),)
-
WRT54G_SOURCE=wrt54gs.2.07.1.tgz
WRT54G_SITE=http://www.linksys.com/support/opensourcecode/wrt54gs/2.07.1
WRT54G_DIR=$(BUILD_DIR)/WRT54GS
@@ -204,7 +202,7 @@ openwrt-rootprep:
######################################################################
-openwrt-prune:
+openwrt-prune: openwrt-base
-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
# remove unneeded uClibc libs
rm -rf $(TARGET_DIR)/lib/libthread_db*
@@ -237,4 +235,3 @@ openwrt-g-code.bin: openwrt-gs-code.bin
openwrt-code.bin: openwrt-gs-code.bin openwrt-g-code.bin
######################################################################
-endif