summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-20 23:57:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-20 23:57:10 +0000
commit99bc02a12be0b7725b2917e2b25c25e446f67717 (patch)
tree8d738503ef199ed6cafb9f837c825e3cfffc4e57 /openwrt/Makefile
parent991cba3cc9b6ebc5c06e39b4b12766452b3e0946 (diff)
downloadmtk-20170518-99bc02a12be0b7725b2917e2b25c25e446f67717.zip
mtk-20170518-99bc02a12be0b7725b2917e2b25c25e446f67717.tar.gz
mtk-20170518-99bc02a12be0b7725b2917e2b25c25e446f67717.tar.bz2
add global make download target
SVN-Revision: 4031
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 92a49bf..faeecaa 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -86,9 +86,16 @@ target/%: .pkginfo FORCE
toolchain/%: FORCE
$(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
-world: ./scripts/config/conf FORCE
- touch .config
+.config: ./scripts/config/conf FORCE
+ @[ -f .config ] || $(MAKE) menuconfig
$< -D .config Config.in >/dev/null 2>/dev/null
+
+download: .config FORCE
+ $(MAKE) toolchain/download
+ $(MAKE) package/download
+ $(MAKE) target/download
+
+world: .config FORCE
$(MAKE) toolchain/install
$(MAKE) target/compile
$(MAKE) package/compile