summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-19 23:02:14 +0000
committerMike Baker <mbm@openwrt.org>2006-05-19 23:02:14 +0000
commita3281a2f3bd6604d02d6543bce188c9adea82708 (patch)
tree5a74ff2ef272dfe36ddaaa89bb22ce6986b2a022 /openwrt/Makefile
parent59c1faa1503df905ebe75e435eebf6fb0de107e2 (diff)
downloadmtk-20170518-a3281a2f3bd6604d02d6543bce188c9adea82708.zip
mtk-20170518-a3281a2f3bd6604d02d6543bce188c9adea82708.tar.gz
mtk-20170518-a3281a2f3bd6604d02d6543bce188c9adea82708.tar.bz2
fix .pkginfo line to allow the use of $(SOURCE)
SVN-Revision: 3802
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 9b9d1c9..9b341f1 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -41,11 +41,11 @@ export OPENWRTVERSION
all:
.pkginfo: FORCE
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
@echo Collecting package info...
- @-for makefile in package/*/Makefile; do \
- echo Source-Makefile: $$makefile; \
- $(MAKE) --no-print-dir DUMP=1 -f $$makefile 2>&- || true; \
+ @-for dir in package/*/; do \
+ echo Source-Makefile: $${dir}Makefile; \
+ $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
done > $@
endif