summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-08-21 23:13:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-08-21 23:13:17 +0000
commitbbda94d4f92cdf74a8cb8963955ff0171dfcb197 (patch)
tree3e053b8de5d102f79fa9c7759545f99c00bd88b2 /openwrt/Makefile
parent34a8300f0d43175eb72fef0f470d72ccd213cb2b (diff)
downloadmtk-20170518-bbda94d4f92cdf74a8cb8963955ff0171dfcb197.zip
mtk-20170518-bbda94d4f92cdf74a8cb8963955ff0171dfcb197.tar.gz
mtk-20170518-bbda94d4f92cdf74a8cb8963955ff0171dfcb197.tar.bz2
fix up TMPDIR for initial prereq check to avoid creating a bogus build_ directory
SVN-Revision: 4617
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 5b90c48..15074c5 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -96,10 +96,11 @@ toolchain/%: FORCE
@touch $@
.prereq-packages: include/prereq.mk .pkginfo .config
- @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+ @$(NO_TRACE_MAKE) -s -C package TMPDIR="$(TOPDIR)/tmp" prereq 2>/dev/null || { \
echo "Prerequisite check failed. Use FORCE=1 to override."; \
false; \
}
+ rm -rf "$(TOPDIR)/tmp"
@touch $@
prereq: .prereq-build .prereq-packages FORCE