summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-30 14:11:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-30 14:11:24 +0000
commitb978be63dfdbf449e1bc1efee3d23573837cf7dd (patch)
tree34a5d3174ef18526ef7a089460bccb60e3dba9ca /openwrt/Makefile
parent82d39bdf24b15f6ce6b543c46881d262a13b76d7 (diff)
downloadmtk-20170518-b978be63dfdbf449e1bc1efee3d23573837cf7dd.zip
mtk-20170518-b978be63dfdbf449e1bc1efee3d23573837cf7dd.tar.gz
mtk-20170518-b978be63dfdbf449e1bc1efee3d23573837cf7dd.tar.bz2
add {package,target,toolchain}/* targets to toplevel makefile
SVN-Revision: 3838
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 9b341f1..96dd2e0 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -70,5 +70,14 @@ config: scripts/config/conf
config-clean:
$(MAKE) -C scripts/config clean
+package/%:
+ $(MAKE) -C toolchain $(patsubst package/%,%,$@)
+
+target/%:
+ $(MAKE) -C toolchain $(patsubst target/%,%,$@)
+
+toolchain/%:
+ $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
.PHONY: FORCE
FORCE: