summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-30 18:55:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-30 18:55:52 +0000
commit5b05f4a5ee5fa1dd3246350b6672d05a1aaa7f4d (patch)
treeb9f40012c0fbad8c3123e42d0ec5439224a0f6fd /openwrt/Makefile
parent10152c5c0752e6e514999056142dacbc8de71d95 (diff)
downloadmtk-20170518-5b05f4a5ee5fa1dd3246350b6672d05a1aaa7f4d.zip
mtk-20170518-5b05f4a5ee5fa1dd3246350b6672d05a1aaa7f4d.tar.gz
mtk-20170518-5b05f4a5ee5fa1dd3246350b6672d05a1aaa7f4d.tar.bz2
improve dependency handling, fix some package makefile bugs
SVN-Revision: 3843
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 8a2e6bb..f93b008 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -70,10 +70,10 @@ config: scripts/config/conf
config-clean:
$(MAKE) -C scripts/config clean
-package/%:
+package/%: .pkginfo
$(MAKE) -C package $(patsubst package/%,%,$@)
-target/%:
+target/%: .pkginfo
$(MAKE) -C target $(patsubst target/%,%,$@)
toolchain/%: