summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-01 00:19:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-01 00:19:52 +0000
commita455258789eedf91d947c529789fd247349bef36 (patch)
tree6bf7da8f66fa1fb77794187eb2ab739ca80128e8 /openwrt/Makefile
parent207bbb56d46cadd356ff19ebf71b2c604e25d8f5 (diff)
downloadmtk-20170518-a455258789eedf91d947c529789fd247349bef36.zip
mtk-20170518-a455258789eedf91d947c529789fd247349bef36.tar.gz
mtk-20170518-a455258789eedf91d947c529789fd247349bef36.tar.bz2
add clean targets, more FORCE stuff
SVN-Revision: 3882
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile27
1 files changed, 18 insertions, 9 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 40b4efc..84508b1 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -61,36 +61,45 @@ scripts/config/mconf: .config.in
scripts/config/conf: .config.in
$(MAKE) -C scripts/config conf
-config: scripts/config/conf
+config: scripts/config/conf FORCE
$< Config.in
-defdconfig: scripts/config/conf
+defdconfig: scripts/config/conf FORCE
$< -d Config.in
-oldconfig: scripts/config/conf
+oldconfig: scripts/config/conf FORCE
$< -o Config.in
-menuconfig: scripts/config/mconf
+menuconfig: scripts/config/mconf FORCE
$< Config.in
-config-clean:
+config-clean: FORCE
$(MAKE) -C scripts/config clean
-package/%: .pkginfo
+package/%: .pkginfo FORCE
$(MAKE) -C package $(patsubst package/%,%,$@)
-target/%: .pkginfo
+target/%: .pkginfo FORCE
$(MAKE) -C target $(patsubst target/%,%,$@)
-toolchain/%:
+toolchain/%: FORCE
$(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
-world:
+world: FORCE
$(MAKE) toolchain/install
$(MAKE) target/compile
$(MAKE) package/compile
$(MAKE) package/install
$(MAKE) target/install
+clean: FORCE
+ rm -rf build_* bin
+
+dirclean: clean FORCE
+ rm -rf staging_dir_* toolchain_build_*
+
+distclean: dirclean FORCE
+ rm -rf .* dl
+
.PHONY: FORCE
FORCE: