summaryrefslogtreecommitdiff
path: root/openwrt/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 21:06:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 21:06:45 +0000
commitddc55842445a938f3271fec0ebc768a373fa071a (patch)
treed4a81ad0d5e48d6595451730383a3d14795e1355 /openwrt/include/host.mk
parent10db4ed4cce4fb8e0c2a2c7b0261071afc8b5994 (diff)
downloadmtk-20170518-ddc55842445a938f3271fec0ebc768a373fa071a.zip
mtk-20170518-ddc55842445a938f3271fec0ebc768a373fa071a.tar.gz
mtk-20170518-ddc55842445a938f3271fec0ebc768a373fa071a.tar.bz2
more portability fixes and a prereq check for gnu tar
SVN-Revision: 5037
Diffstat (limited to 'openwrt/include/host.mk')
-rw-r--r--openwrt/include/host.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/include/host.mk b/openwrt/include/host.mk
index abcf045..3a5fd96 100644
--- a/openwrt/include/host.mk
+++ b/openwrt/include/host.mk
@@ -7,6 +7,8 @@
include $(TOPDIR)/.host.mk
+export TAR
+
$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
@( \
HOST_OS=`uname`; \
@@ -23,5 +25,7 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
echo "TAR_WILDCARDS:=--wildcards" >> $@; \
fi; \
+ TAR=`which gtar tar | head -n 1`; \
+ echo "TAR:=$$TAR" >> $@; \
)