summaryrefslogtreecommitdiff
path: root/openwrt/include/package.mk
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-07-10 23:21:08 +0000
committerMike Baker <mbm@openwrt.org>2006-07-10 23:21:08 +0000
commitddf3a0c11135924be3ffd3d40cb6484c5ca1651a (patch)
treedd26d63ce8da273dc11e6ac758c21145592ecba5 /openwrt/include/package.mk
parente81ba9aa44cd444fbbecb37ac38b01da6298fa98 (diff)
downloadmtk-20170518-ddf3a0c11135924be3ffd3d40cb6484c5ca1651a.zip
mtk-20170518-ddf3a0c11135924be3ffd3d40cb6484c5ca1651a.tar.gz
mtk-20170518-ddf3a0c11135924be3ffd3d40cb6484c5ca1651a.tar.bz2
rebuild ipkg control files if Makefile changes
SVN-Revision: 4124
Diffstat (limited to 'openwrt/include/package.mk')
-rw-r--r--openwrt/include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/include/package.mk b/openwrt/include/package.mk
index 618c3c5..7aea314 100644
--- a/openwrt/include/package.mk
+++ b/openwrt/include/package.mk
@@ -173,7 +173,7 @@ define BuildPackage
$(eval $(call BuildIPKGVariable,$(1),postinst))
$(eval $(call BuildIPKGVariable,$(1),prerm))
$(eval $(call BuildIPKGVariable,$(1),postrm))
- $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
+ $$(IDIR_$(1))/CONTROL/control: Makefile $(PKG_BUILD_DIR)/.prepared
mkdir -p $$(IDIR_$(1))/CONTROL
echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control