summaryrefslogtreecommitdiff
path: root/openwrt/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-22 00:59:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-22 00:59:47 +0000
commit03c1cb3444dcfe4bcc8df3f7eead9ba681324055 (patch)
treea12876f30af2a65cb6dba174556d01fd1a96973c /openwrt/include
parentf6d85c09dd3a588e7afb72d0bb9c4120499c0ed4 (diff)
downloadmtk-20170518-03c1cb3444dcfe4bcc8df3f7eead9ba681324055.zip
mtk-20170518-03c1cb3444dcfe4bcc8df3f7eead9ba681324055.tar.gz
mtk-20170518-03c1cb3444dcfe4bcc8df3f7eead9ba681324055.tar.bz2
add 0xdeadc0de to the jffs2 filesystem images
SVN-Revision: 4048
Diffstat (limited to 'openwrt/include')
-rw-r--r--openwrt/include/image.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/include/image.mk b/openwrt/include/image.mk
index f30f099..bf80e27 100644
--- a/openwrt/include/image.mk
+++ b/openwrt/include/image.mk
@@ -17,6 +17,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
$(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
+
+ # add End-of-Filesystem markers
+ echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
+ echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
$(call Image/Build,jffs2-64k)
$(call Image/Build,jffs2-128k)