summaryrefslogtreecommitdiff
path: root/openwrt/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-09-07 12:14:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-09-07 12:14:08 +0000
commit550bdc5f804f2b3ed7c0286fe8f0e6cfdf3bc5a0 (patch)
tree914e2ffa5a110482462a4a6a42056f3b7a9c57d3 /openwrt/include
parentf064d2375bdee193405155fef94c6e56b403da31 (diff)
downloadmtk-20170518-550bdc5f804f2b3ed7c0286fe8f0e6cfdf3bc5a0.zip
mtk-20170518-550bdc5f804f2b3ed7c0286fe8f0e6cfdf3bc5a0.tar.gz
mtk-20170518-550bdc5f804f2b3ed7c0286fe8f0e6cfdf3bc5a0.tar.bz2
fix unnecessary rebuilds for library package directories with no selected packages
SVN-Revision: 4767
Diffstat (limited to 'openwrt/include')
-rw-r--r--openwrt/include/package.mk25
1 files changed, 14 insertions, 11 deletions
diff --git a/openwrt/include/package.mk b/openwrt/include/package.mk
index 9a947f3..515698d 100644
--- a/openwrt/include/package.mk
+++ b/openwrt/include/package.mk
@@ -17,20 +17,10 @@ define Build/DefaultTargets
ifeq ($(CONFIG_AUTOREBUILD),y)
_INFO:=
ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
- _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
+ _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
$(PKG_BUILD_DIR)/.prepared: package-clean
endif
- ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
- _INFO+=$(subst $(TOPDIR)/,,$(IPKG_$(1)))
- $(PKG_BUILD_DIR)/.built: package-rebuild
- endif
-
- ifneq ($(MAKECMDGOALS),prereq)
- ifneq ($$(_INFO),)
- $$(info Rebuilding $$(_INFO))
- endif
- endif
endif
endif
@@ -241,6 +231,19 @@ define BuildPackage
@touch $$@
$$(eval $$(call Build/DefaultTargets,$(1)))
+
+ ifneq ($$(CONFIG_PACKAGE_$(1)),)
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$$(IPKG_$(1)))
+ _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+ $(PKG_BUILD_DIR)/.built: package-rebuild
+ endif
+
+ ifneq ($(MAKECMDGOALS),prereq)
+ ifneq ($$(_INFO),)
+ $$(info Rebuilding $$(_INFO))
+ endif
+ endif
+ endif
endef
ifneq ($(strip $(PKG_CAT)),)