summaryrefslogtreecommitdiff
path: root/openwrt/include
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-08-30 10:26:30 +0000
committerMike Baker <mbm@openwrt.org>2006-08-30 10:26:30 +0000
commita5b58128b02ec8e542abe1adb596a3099eb8e10a (patch)
tree100c1c117c0d301cd9e2821a570f2267c0a00dea /openwrt/include
parent7b8d2827f550a24518cd60029d228a301fa1e1e2 (diff)
downloadmtk-20170518-a5b58128b02ec8e542abe1adb596a3099eb8e10a.zip
mtk-20170518-a5b58128b02ec8e542abe1adb596a3099eb8e10a.tar.gz
mtk-20170518-a5b58128b02ec8e542abe1adb596a3099eb8e10a.tar.bz2
fix previous commit
SVN-Revision: 4716
Diffstat (limited to 'openwrt/include')
-rw-r--r--openwrt/include/package.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/openwrt/include/package.mk b/openwrt/include/package.mk
index ce3c4b6..8d90509 100644
--- a/openwrt/include/package.mk
+++ b/openwrt/include/package.mk
@@ -237,7 +237,7 @@ define BuildPackage
clean: $(1)-clean
$(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
- -rm $(PKG_BUILD_DIR)/.version-$(1)_*
+ -@rm $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
@touch $$@
$$(eval $$(call Build/DefaultTargets,$(1)))
@@ -263,7 +263,7 @@ endef
define Build/Configure/Default
@(cd $(PKG_BUILD_DIR)/$(3); \
- [ -x configure ] && { \
+ [ \! -x configure ] || \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -287,7 +287,6 @@ define Build/Configure/Default
--infodir=/usr/info \
$(DISABLE_NLS) \
$(1); \
- } || true; \
)
endef