summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-14 16:27:48 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-14 16:27:48 +0000
commit0869de5f056a9633d58ffaa1ce5930b6e00c8eb3 (patch)
treec74524546a450b64ffd88cc7313f48e9961afbb1 /openwrt/package/Makefile
parent10be238e537af97ba021632817b0f967c92ab8a3 (diff)
downloadmtk-20170518-0869de5f056a9633d58ffaa1ce5930b6e00c8eb3.zip
mtk-20170518-0869de5f056a9633d58ffaa1ce5930b6e00c8eb3.tar.gz
mtk-20170518-0869de5f056a9633d58ffaa1ce5930b6e00c8eb3.tar.bz2
add php5 package
SVN-Revision: 1667
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 0344b79..63cd737 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -106,6 +106,7 @@ package-$(BR2_PACKAGE_OSIRIS) += osiris
package-$(BR2_PACKAGE_PARPROUTED) += parprouted
package-$(BR2_PACKAGE_PCRE) += pcre
package-$(BR2_COMPILE_PHP4) += php4
+package-$(BR2_COMPILE_PHP5) += php5
package-$(BR2_PACKAGE_PICOCOM) += picocom
package-$(BR2_PACKAGE_PMACCT) += pmacct
package-$(BR2_PACKAGE_POPT) += popt
@@ -273,6 +274,29 @@ ifneq ($(BR2_PACKAGE_PHP4_MOD_XML),)
php4-compile: expat-compile
endif
+php5-compile: openssl-compile zlib-compile
+ifneq ($(BR2_PACKAGE_PHP5_MOD_GD),)
+php5-compile: libgd-compile libpng-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_LDAP),)
+php5-compile: openldap-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_MYSQL),)
+php5-compile: mysql-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_PCRE),)
+php5-compile: pcre-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_PGSQL),)
+php5-compile: postgresql-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_SQLITE),)
+php5-compile: sqlite2-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_XML),)
+php5-compile: expat-compile
+endif
+
pmacct-compile: libpcap-compile
ifneq ($(BR2_PACKAGE_PMACCT_MYSQL),)
pmacct-compile: mysql-compile