summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 03:17:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 03:17:13 +0000
commit1f20179ce5c9774f17d843070cd39da3f2e62268 (patch)
treedd84406a853da04c25ef9af1fdd51f243a395d7c /openwrt/package/Makefile
parent6449bbd082dc0fdfa2b41efd0283d281be1e6c07 (diff)
downloadmtk-20170518-1f20179ce5c9774f17d843070cd39da3f2e62268.zip
mtk-20170518-1f20179ce5c9774f17d843070cd39da3f2e62268.tar.gz
mtk-20170518-1f20179ce5c9774f17d843070cd39da3f2e62268.tar.bz2
fix and enable the sdk
SVN-Revision: 4037
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 2b7f0db..e947bcf 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -27,9 +27,12 @@ $(STAMP_DIR) $(TARGET_DIR):
%-clean: $(STAMP_DIR) $(TARGET_DIR)
$(MAKE) -C $(patsubst %-clean,%,$@) clean MAKEFLAGS="$(BUILD_MAKEFLAGS)"
+ifeq ($(SDK),1)
+GENDEP_OPTS := -s
+endif
$(TOPDIR)/.pkgdeps: $(TOPDIR)/.pkginfo
- @$(TOPDIR)/scripts/gen_deps.pl < $< > $@ || rm -f $@
+ @$(TOPDIR)/scripts/gen_deps.pl $(GENDEP_OPTS) < $< > $@ || rm -f $@
all: compile
clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))