summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 14:15:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 14:15:32 +0000
commit43eabb4e66bb0573ebe7d6b2978bef4a3a91c674 (patch)
tree58d0ce25a1c9edbaf9a0610aba55de484db061c0 /openwrt/package/Makefile
parent447eef2bae8fc1e14d42a4f0c08f9803b505229f (diff)
downloadmtk-20170518-43eabb4e66bb0573ebe7d6b2978bef4a3a91c674.zip
mtk-20170518-43eabb4e66bb0573ebe7d6b2978bef4a3a91c674.tar.gz
mtk-20170518-43eabb4e66bb0573ebe7d6b2978bef4a3a91c674.tar.bz2
add id3lib to sdk depends, change package compile depends
SVN-Revision: 2237
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 91307cd..0bddabb 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -206,7 +206,7 @@ package-$(BR2_PACKAGE_XINETD) += xinetd
package-$(BR2_PACKAGE_XSUPPLICANT) += xsupplicant
package-$(BR2_PACKAGE_ZLIB) += zlib
-DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd wireless-tools nvram linux-atm libamsel libao libart libdaemon libdb libdnet libevent libffi-sable libgcrypt libgdbm libgpg-error libid3tag libmad libnet libnids libogg libosip2 libpcap libtasn1 libupnp libusb libvorbis libvorbisidec libxml2 libxslt
+DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd wireless-tools nvram linux-atm libamsel libao libart libdaemon libdb libdnet libevent libffi-sable libgcrypt libgdbm libgpg-error libid3tag libmad libnet libnids libogg libosip2 libpcap libtasn1 libupnp libusb libvorbis libvorbisidec libxml2 libxslt id3lib
DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge ipkg ppp
SDK_DEFAULT_COMPILE:=$(patsubst %,%-compile,$(SDK_DEFAULT_PACKAGES))
@@ -447,11 +447,12 @@ $(TARGET_DIR):
}
@touch $(STAMP_DIR)/.$@
-%-compile: %-prepare
+%-compile:
@[ -f $(STAMP_DIR)/.$@ ] || { \
$(TRACE) package/$(patsubst %-compile,%,$@)/compile; \
$(MAKE) -C $(patsubst %-compile,%,$@) compile; \
}
+ @touch $(STAMP_DIR)/.$(patsubst %-compile,%,$@)-prepare
@touch $(STAMP_DIR)/.$@
%-install: %-compile