summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-20 17:01:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-20 17:01:30 +0000
commitb6defb27cbb3f978cbf66f92f4379eeb1318b83a (patch)
treed54625559910142e0895d8a2318d003de21a286c /openwrt/package/Makefile
parentb00ba37ec09d2d802a42d98ca6b8d32b3a0dfda2 (diff)
downloadmtk-20170518-b6defb27cbb3f978cbf66f92f4379eeb1318b83a.zip
mtk-20170518-b6defb27cbb3f978cbf66f92f4379eeb1318b83a.tar.gz
mtk-20170518-b6defb27cbb3f978cbf66f92f4379eeb1318b83a.tar.bz2
add openwrt image builder to sdk
SVN-Revision: 688
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index bd93880..4008d43 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -66,6 +66,8 @@ package-$(BR2_PACKAGE_LIBPQ) += postgresql
DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf
DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
+SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge
+SDK_DEFAULT_COMPILE:=$(patsubst %,%-compile,$(SDK_DEFAULT_PACKAGES))
all: compile install
clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m)) linux-clean
@@ -106,7 +108,7 @@ ifeq ($(BR2_PACKAGE_SNORT_PGSQL),y)
snort-compile: postgresql-compile
endif
-sdk-compile: $(DEV_LIBS_COMPILE)
+sdk-compile: $(DEV_LIBS_COMPILE) $(SDK_DEFAULT_COMPILE)
$(patsubst %,%-prepare,$(package-y) $(package-m) $(package-)): linux-install
%-prepare: