summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-05 14:45:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-05 14:45:48 +0000
commitde56a161ac1d9496c5efc9ef8539f5dded05c89c (patch)
treec487d546681dbabe3d4fde1f55778add9dd462b8 /openwrt/package/Makefile
parent981d0433773f67b9d233a57e6f6a8acd9e5798d3 (diff)
downloadmtk-20170518-de56a161ac1d9496c5efc9ef8539f5dded05c89c.zip
mtk-20170518-de56a161ac1d9496c5efc9ef8539f5dded05c89c.tar.gz
mtk-20170518-de56a161ac1d9496c5efc9ef8539f5dded05c89c.tar.bz2
add %-rebuild target for package/
SVN-Revision: 1150
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 3895838..8d7dd75 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -216,6 +216,10 @@ sdk-compile: $(DEV_LIBS_COMPILE) $(SDK_DEFAULT_COMPILE) openwrt-install
@[ -f $(STAMP_DIR)/.$@ ] || $(MAKE) -C $(patsubst %-install,%,$@) install
@touch $(STAMP_DIR)/.$@
+%-rebuild:
+ @rm -f $(STAMP_DIR)/.$(patsubst %-rebuild,%,$@)-*
+ $(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
+
%-clean:
@$(MAKE) -C $(patsubst %-clean,%,$@) clean
@rm -f $(STAMP_DIR)/.$(patsubst %-clean,%,$@)-*