summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-19 00:16:27 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-19 00:16:27 +0000
commit9056ac5ca0fadfa778ae21013ff3a7bf4010e383 (patch)
tree7b91c79d3e371a427cdb33e01139c280aafcde9a /openwrt/package/Makefile
parent5824225005e76a5d63e0002bf8895104631e494c (diff)
downloadmtk-20170518-9056ac5ca0fadfa778ae21013ff3a7bf4010e383.zip
mtk-20170518-9056ac5ca0fadfa778ae21013ff3a7bf4010e383.tar.gz
mtk-20170518-9056ac5ca0fadfa778ae21013ff3a7bf4010e383.tar.bz2
add a patch to provide a descent PATH to cgi, split in 3 packages (w/o ssl, w/ matrixssl & w/ openssl), add a restart command to init-script.
SVN-Revision: 2174
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 3c56620..5e5087d 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -107,7 +107,7 @@ package-$(BR2_PACKAGE_MARADNS) += maradns
package-$(BR2_PACKAGE_MATRIXSSL) += matrixssl
package-$(BR2_PACKAGE_MICROCOM) += microcom
package-$(BR2_PACKAGE_MICROPERL) += microperl
-package-$(BR2_PACKAGE_MINI_HTTPD) += mini_httpd
+package-$(BR2_COMPILE_MINI_HTTPD) += mini_httpd
package-$(BR2_PACKAGE_MINI_SENDMAIL) += mini_sendmail
package-$(BR2_PACKAGE_MONIT) += monit
package-$(BR2_PACKAGE_MPD) += mpd
@@ -248,7 +248,6 @@ libvorbis-compile: libogg-compile
libxml2-compile: zlib-compile
libxslt-compile: libxml2-compile
lighttpd-compile: openssl-compile pcre-compile
-mini_httpd-compile: matrixssl-compile
mt-daapd-compile: howl-compile libgdbm-compile libid3tag-compile
mtr-compile: ncurses-compile
mysql-compile: ncurses-compile zlib-compile
@@ -314,6 +313,13 @@ ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_SQL_PGSQL),)
freeradius-compile: postgresql-compile
endif
+ifneq ($(BR2_PACKAGE_MINI_HTTPD_MATRIXSSL),)
+mini_httpd-compile: matrixssl-compile
+endif
+ifneq ($(BR2_PACKAGE_MINI_HTTPD_OPENSSL),)
+mini_httpd-compile: openssl-compile
+endif
+
ifneq ($(BR2_PACKAGE_MPD_MP3),)
mpd-compile: libid3tag-compile libmad-compile
endif