summaryrefslogtreecommitdiff
path: root/openwrt/package/alsa/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-09-27 05:54:37 +0000
committerNicolas Thill <nico@openwrt.org>2006-09-27 05:54:37 +0000
commitb19959e2dc4968e26a7918d69015319884d83fd8 (patch)
tree78ea38dbe354cf5e7995c6899c86cd65be4d6cfa /openwrt/package/alsa/Makefile
parent014e097b1a1da4ba4fd8b69f7c9c3aef041859c9 (diff)
downloadmtk-20170518-b19959e2dc4968e26a7918d69015319884d83fd8.zip
mtk-20170518-b19959e2dc4968e26a7918d69015319884d83fd8.tar.gz
mtk-20170518-b19959e2dc4968e26a7918d69015319884d83fd8.tar.bz2
fix alsa on 2.6 (some arches need specific includes)
SVN-Revision: 4859
Diffstat (limited to 'openwrt/package/alsa/Makefile')
-rw-r--r--openwrt/package/alsa/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/openwrt/package/alsa/Makefile b/openwrt/package/alsa/Makefile
index d82d87a..47ad445 100644
--- a/openwrt/package/alsa/Makefile
+++ b/openwrt/package/alsa/Makefile
@@ -33,14 +33,18 @@ endef
ifeq ($(KERNEL),2.4)
ifeq ($(LINUX_KARCH),i386)
- KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
endif
ifeq ($(LINUX_KARCH),mips)
- KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
endif
endif
+ifeq ($(LINUX_KARCH),i386)
+ KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
+endif
+ifeq ($(LINUX_KARCH),mips)
+ KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
+endif
define Build/Configure
(cd $(PKG_BUILD_DIR); \