summaryrefslogtreecommitdiff
path: root/openwrt/package/alsa/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-09-23 13:24:00 +0000
committerNicolas Thill <nico@openwrt.org>2006-09-23 13:24:00 +0000
commitc48beb25ff87790c5e10e0bc57589527c1483ba3 (patch)
tree928dbffe3094ed5fada810bb0356f048e91ce368 /openwrt/package/alsa/Makefile
parenta92a3ce6fb76e50c7ea4d18feb1e5ad0b4258d77 (diff)
downloadmtk-20170518-c48beb25ff87790c5e10e0bc57589527c1483ba3.zip
mtk-20170518-c48beb25ff87790c5e10e0bc57589527c1483ba3.tar.gz
mtk-20170518-c48beb25ff87790c5e10e0bc57589527c1483ba3.tar.bz2
standardize Makefile, only use includes and optimizations on 2.4
SVN-Revision: 4811
Diffstat (limited to 'openwrt/package/alsa/Makefile')
-rw-r--r--openwrt/package/alsa/Makefile55
1 files changed, 28 insertions, 27 deletions
diff --git a/openwrt/package/alsa/Makefile b/openwrt/package/alsa/Makefile
index 887404c..ebfb6f8 100644
--- a/openwrt/package/alsa/Makefile
+++ b/openwrt/package/alsa/Makefile
@@ -12,47 +12,48 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=alsa-driver
PKG_VERSION:=1.0.11
PKG_RELEASE:=1
-PKG_MD5SUM:=57534e4297cd683371402220e3753885
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
+PKG_MD5SUM:=57534e4297cd683371402220e3753885
PKG_CAT:=bzcat
include $(INCLUDE_DIR)/package.mk
-ifeq ($(LINUX_KARCH),i386)
-KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
-KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
-endif
-ifeq ($(LINUX_KARCH),mips)
-KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
-KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
-endif
-
define Package/kmod-alsa
-SECTION:=drivers
-CATEGORY:=Drivers
-DEPENDS:=@USB_SUPPORT
-TITLE:=Advanced Linux Sound Architecture
-DESCRIPTION:=Advanced Linux Sound Architecture
-URL:=http://alsa-project.org/
-VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+ SECTION:=kernel
+ CATEGORY:=Kernel drivers
+ DEPENDS:=@USB_SUPPORT
+ TITLE:=Advanced Linux Sound Architecture
+ URL:=http://alsa-project.org/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
endef
+ifeq ($(KERNEL),2.4)
+ ifeq ($(LINUX_KARCH),i386)
+ KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
+ KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
+ endif
+ ifeq ($(LINUX_KARCH),mips)
+ KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
+ KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
+ endif
+endif
+
define Build/Configure
(cd $(PKG_BUILD_DIR); \
CFLAGS="$(KERNEL_C_INCS)" \
./configure \
- --with-build=$(LINUX_DIR) \
- --with-kernel=$(LINUX_DIR) \
- --with-cross=$(KERNEL_CROSS) \
- --with-redhat=no \
- --with-suse=no \
- --with-oss=yes \
- --with-isapnp=no \
- --with-sequencer=no \
- --with-cards=usb-audio \
+ --with-build="$(LINUX_DIR)" \
+ --with-kernel="$(LINUX_DIR)" \
+ --with-cross="$(KERNEL_CROSS)" \
+ --with-redhat=no \
+ --with-suse=no \
+ --with-oss=yes \
+ --with-isapnp=no \
+ --with-sequencer=no \
+ --with-cards=usb-audio \
);
endef