summaryrefslogtreecommitdiff
path: root/openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-11 12:48:09 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-11 12:48:09 +0000
commit92846b914a8c1e3abffe480813183f16c1425290 (patch)
tree7196b03459252abed6f51691e6558b6f61d6d96f /openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
parentb046439bf8e2c52e951cd8160ffee8788585eba5 (diff)
downloadmtk-20170518-92846b914a8c1e3abffe480813183f16c1425290.zip
mtk-20170518-92846b914a8c1e3abffe480813183f16c1425290.tar.gz
mtk-20170518-92846b914a8c1e3abffe480813183f16c1425290.tar.bz2
Update to new upstream release (v1.0.9), Split makefile patch into multiple patches, Add no-gtk fix from whiterussian.
SVN-Revision: 1402
Diffstat (limited to 'openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch')
-rw-r--r--openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch b/openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
new file mode 100644
index 0000000..8d89328
--- /dev/null
+++ b/openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
@@ -0,0 +1,33 @@
+diff -ruN asterisk-1.0.7-old/channels/h323/Makefile asterisk-1.0.7-new/channels/h323/Makefile
+--- asterisk-1.0.7-old/channels/h323/Makefile 2004-11-15 03:35:35.000000000 +0100
++++ asterisk-1.0.7-new/channels/h323/Makefile 2005-03-19 17:38:06.000000000 +0100
+@@ -22,9 +22,11 @@
+ OSARCH=$(shell uname -s)
+ ifneq (${OSARCH},FreeBSD)
+ ifneq (${OSARCH},NetBSD)
++ifneq ($(PROC),mipsel)
+ CFLAGS += -march=$(shell uname -m)
+ endif
+ endif
++endif
+ CFLAGS += -DPBYTE_ORDER=PLITTLE_ENDIAN
+
+ ifeq (${OSARCH},Linux)
+@@ -47,7 +49,7 @@
+
+ # Pre Janus release directives
+ CFLAGS += -DNDEBUG -DDO_CRASH -DDEBUG_THREADS
+-CFLAGS += -pipe -Wall -fPIC
++CFLAGS += -pipe -Wall -fPIC $(OPTIMIZE)
+ ifeq (${OSARCH},Linux)
+ CFLAGS += -DP_LINUX
+ LIBS+=-lpthread
+@@ -74,7 +76,7 @@
+
+
+ libchanh323.a: ast_h323.o
+- ar cr libchanh323.a ast_h323.o
++ $(AR) cr libchanh323.a ast_h323.o
+
+ ast_h323.o: ast_h323.cpp
+ $(CXX) -g -c -fno-rtti -o $@ $(CFLAGS) $<