summaryrefslogtreecommitdiff
path: root/openwrt/package/asterisk
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-01-13 17:32:38 +0000
committerMike Baker <mbm@openwrt.org>2006-01-13 17:32:38 +0000
commita7aa8530f87ddce4547951bba7e4f7c1d03d7441 (patch)
tree2a296cd05732fd74916765bf3b269bd03e8bbc70 /openwrt/package/asterisk
parent604fdbb9323b6008ade990e35b8c7557882d2ff5 (diff)
downloadmtk-20170518-a7aa8530f87ddce4547951bba7e4f7c1d03d7441.zip
mtk-20170518-a7aa8530f87ddce4547951bba7e4f7c1d03d7441.tar.gz
mtk-20170518-a7aa8530f87ddce4547951bba7e4f7c1d03d7441.tar.bz2
patch for big endian
SVN-Revision: 2954
Diffstat (limited to 'openwrt/package/asterisk')
-rw-r--r--openwrt/package/asterisk/patches/asterisk-1.2.0-Makefile-codecs-gsm.patch12
1 files changed, 8 insertions, 4 deletions
diff --git a/openwrt/package/asterisk/patches/asterisk-1.2.0-Makefile-codecs-gsm.patch b/openwrt/package/asterisk/patches/asterisk-1.2.0-Makefile-codecs-gsm.patch
index ec49daf..372d697 100644
--- a/openwrt/package/asterisk/patches/asterisk-1.2.0-Makefile-codecs-gsm.patch
+++ b/openwrt/package/asterisk/patches/asterisk-1.2.0-Makefile-codecs-gsm.patch
@@ -1,35 +1,39 @@
diff -ruN asterisk-1.2.0-old/codecs/gsm/Makefile asterisk-1.2.0-new/codecs/gsm/Makefile
--- asterisk-1.2.0-old/codecs/gsm/Makefile 2005-11-08 04:31:45.000000000 +0100
+++ asterisk-1.2.0-new/codecs/gsm/Makefile 2005-12-04 13:31:50.000000000 +0100
-@@ -236,6 +236,7 @@
+@@ -236,6 +236,8 @@
ifneq ($(shell uname -m),armv4l)
ifneq ($(shell uname -m),sparc64)
ifneq (${PROC},arm)
+ifneq (${PROC},mipsel)
++ifneq (${PROC},mips)
GSM_SOURCES+= $(SRC)/k6opt.s
endif
endif
-@@ -245,6 +246,7 @@
+@@ -246,6 +247,8 @@
endif
endif
endif
+endif
++endif
TOAST_SOURCES = $(SRC)/toast.c \
$(SRC)/toast_lin.c \
-@@ -297,6 +299,7 @@
+@@ -299,6 +301,8 @@
ifneq ($(shell uname -m), alpha)
ifneq ($(shell uname -m), sparc64)
ifneq ($(shell uname -m), armv4l)
+ifneq (${PROC}, mipsel)
++ifneq (${PROC}, mips)
GSM_OBJECTS+= $(SRC)/k6opt.o
endif
endif
-@@ -305,6 +308,7 @@
+@@ -308,6 +311,8 @@
endif
endif
endif
+endif
++endif
TOAST_OBJECTS = $(SRC)/toast.o \
$(SRC)/toast_lin.o \