summaryrefslogtreecommitdiff
path: root/openwrt/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-29 11:30:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-29 11:30:06 +0000
commit45e7d063935cba4eb4567b9aa95279e72d35d2a2 (patch)
treeacec42829c655449ac0828180523cb64ee6fea1f /openwrt/package/base-files/Makefile
parent55fd1cd74eca0b641fa93f965ef6c72057b7fb8f (diff)
downloadmtk-20170518-45e7d063935cba4eb4567b9aa95279e72d35d2a2.zip
mtk-20170518-45e7d063935cba4eb4567b9aa95279e72d35d2a2.tar.gz
mtk-20170518-45e7d063935cba4eb4567b9aa95279e72d35d2a2.tar.bz2
add support for per-package prereq checks, run global prereq checks before (menu-)config
SVN-Revision: 4318
Diffstat (limited to 'openwrt/package/base-files/Makefile')
-rw-r--r--openwrt/package/base-files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index 01ea967..e41e1fd 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -22,8 +22,8 @@ include $(INCLUDE_DIR)/package.mk
ifneq ($(DUMP),1)
TARGET:=-$(BOARD)-$(KERNEL)
-UCLIBC_VERSION:=${shell cat $(STAGING_DIR)/uclibc_version}
-LIBGCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version}
+UCLIBC_VERSION:=${shell cat $(STAGING_DIR)/uclibc_version 2>/dev/null}
+LIBGCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version 2>/dev/null}
else
UCLIBC_VERSION:=<UCLIBC_VERSION>
LIBGCC_VERSION:=<LIBGCC_VERSION>