summaryrefslogtreecommitdiff
path: root/openwrt/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-15 10:43:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-15 10:43:09 +0000
commit8781da9dec882d153fa66002e2d92aaa67e455dc (patch)
tree64b0e1c80fca3ab7a88ee4a86470d9e79fd61cd1 /openwrt/package/base-files/Makefile
parentf9789428092a74816e597ad9a259105cd371b50b (diff)
downloadmtk-20170518-8781da9dec882d153fa66002e2d92aaa67e455dc.zip
mtk-20170518-8781da9dec882d153fa66002e2d92aaa67e455dc.tar.gz
mtk-20170518-8781da9dec882d153fa66002e2d92aaa67e455dc.tar.bz2
add fixes from whiterussian
SVN-Revision: 1683
Diffstat (limited to 'openwrt/package/base-files/Makefile')
-rw-r--r--openwrt/package/base-files/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index f0394f8..af60baf 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -50,9 +50,9 @@ $(IPKG_BASE):
$(IPKG_LIBC):
$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBC) ipkg/uclibc.control $(LIBC_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(IDIR_LIBC)/lib
- cp -fpR $(STAGING_DIR)/lib/ld-uClibc*.so.* $(IDIR_LIBC)/lib/
+ cp $(STAGING_DIR)/lib/ld-uClibc*.so.* $(IDIR_LIBC)/lib/
for file in c crypt dl m nsl resolv rt uClibc util; do \
- cp -fpR $(STAGING_DIR)/lib/lib$$file*.so.* $(IDIR_LIBC)/lib/; \
+ cp $(STAGING_DIR)/lib/lib$$file*.so.* $(IDIR_LIBC)/lib/; \
done
-$(STRIP) $(IDIR_LIBC)/lib/*
$(IPKG_BUILD) $(IDIR_LIBC) $(PACKAGE_DIR)
@@ -64,6 +64,9 @@ $(IPKG_GCC):
-$(STRIP) $(IDIR_GCC)/lib/*
$(IPKG_BUILD) $(IDIR_GCC) $(PACKAGE_DIR)
+package-clean:
+ rm -f $(PACKAGES)
+clean: package-clean
prepare:
compile: $(PACKAGES)
install: compile