summaryrefslogtreecommitdiff
path: root/openwrt/package/base-files/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-05-31 06:49:51 +0000
committerNicolas Thill <nico@openwrt.org>2006-05-31 06:49:51 +0000
commitc664a4aef7f81ded19545c02cec1085b83b18ff1 (patch)
treed7829c3811bb9187f99abe90ec4bb94691db564d /openwrt/package/base-files/Makefile
parentd937c0222385b9ef78d1120421d5aad4a006740a (diff)
downloadmtk-20170518-c664a4aef7f81ded19545c02cec1085b83b18ff1.zip
mtk-20170518-c664a4aef7f81ded19545c02cec1085b83b18ff1.tar.gz
mtk-20170518-c664a4aef7f81ded19545c02cec1085b83b18ff1.tar.bz2
fix base-files packages build.
SVN-Revision: 3852
Diffstat (limited to 'openwrt/package/base-files/Makefile')
-rw-r--r--openwrt/package/base-files/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index 252fa7e..2637949 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -18,6 +18,10 @@ endif
include $(TOPDIR)/package/rules.mk
+#FIXME: use the version from ./toolchain/uclibc
+UCLIBC_VERSION:=0.9.28
+LIBGCC_VERSION:=$(CONFIG_GCC_VERSION)
+
define Package/base-files
SECTION:=base
CATEGORY:=Base system
@@ -26,7 +30,6 @@ define Package/base-files
DESCRIPTION:=OpenWrt system scripts
endef
-
define Package/libgcc
SECTION:=libs
CATEGORY:=Libraries
@@ -53,8 +56,8 @@ endef
define Package/base-files/install
$(CP) ./default/* $(1)
- $(SED) 's,$$R,r$(REV),g' $(1)/etc/banner
- $(SED) 's,$$S,$(BOARD)-$(KERNEL),g' $(1)/etc/ipkg.conf
+ $(SED) 's,$$$$R,r$(REV),g' $(1)/etc/banner
+ $(SED) 's,$$$$S,$(BOARD)-$(KERNEL),g' $(1)/etc/ipkg.conf
mkdir -p $(1)/dev
mkdir -p $(1)/etc/crontabs
mkdir -p $(1)/jffs
@@ -79,14 +82,14 @@ endef
define Package/uclibc/install
mkdir -p $(1)/lib
for file in ld-uClibc libc libcrypt libdl libm libnsl libresolv librt libuClibc libutil; do \
- $(CP) $(STAGING_DIR)/lib/$$file.so.* $(1)/lib/; \
- $(CP) $(STAGING_DIR)/lib/$$file-$(UCLIBC_VERSION).so $(1)/lib/; \
+ $(CP) $(STAGING_DIR)/lib/$$$$file.so.* $(1)/lib/; \
+ $(CP) $(STAGING_DIR)/lib/$$$$file-$(UCLIBC_VERSION).so $(1)/lib/; \
done
endef
define Package/libgcc/install
- mkdir -p $(IDIR_LIBGCC)/lib
- $(CP) $(STAGING_DIR)/lib/libgcc_s.so.* $(IDIR_LIBGCC)/lib/
+ mkdir -p $(1)/lib
+ $(CP) $(STAGING_DIR)/lib/libgcc_s.so.* $(1)/lib/
endef
$(eval $(call BuildPackage,base-files))