summaryrefslogtreecommitdiff
path: root/openwrt/package/bind
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 10:54:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 10:54:33 +0000
commitaddb2f096a950569ba275517eb17fd2b5a06db62 (patch)
tree27cfad9a0b7081ca4bb7e3737081953d6ec6a96c /openwrt/package/bind
parent7bc88ebb13a2e43ecc37c3670ab855abe819214e (diff)
downloadmtk-20170518-addb2f096a950569ba275517eb17fd2b5a06db62.zip
mtk-20170518-addb2f096a950569ba275517eb17fd2b5a06db62.tar.gz
mtk-20170518-addb2f096a950569ba275517eb17fd2b5a06db62.tar.bz2
more fixes for the V= stuff
SVN-Revision: 2225
Diffstat (limited to 'openwrt/package/bind')
-rw-r--r--openwrt/package/bind/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/bind/Makefile b/openwrt/package/bind/Makefile
index 934c582..eeb428a 100644
--- a/openwrt/package/bind/Makefile
+++ b/openwrt/package/bind/Makefile
@@ -20,7 +20,7 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,BIND_SERVER,bind-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,BIND_CLIENT,bind-client,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(strip $(TARGET_CFLAGS))" \
@@ -55,7 +55,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
);
touch $(PKG_BUILD_DIR)/.configured
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
CC="$(HOSTCC)" \
CFLAGS="-O2" \
@@ -65,7 +65,7 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
- touch $(PKG_BUILD_DIR)/.built
+ touch $@
$(IPKG_BIND_SERVER):
install -d -m0755 $(IDIR_BIND_SERVER)/usr/sbin