summaryrefslogtreecommitdiff
path: root/openwrt/package/bluez-libs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 12:12:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 12:12:59 +0000
commit6b758a5dc3bc19877e9c3eefc12ce04d7041334f (patch)
tree4478a1a9bc90bda0dab2c84fce154218f3e11aae /openwrt/package/bluez-libs
parent9ae81d33764adae7a2a68cd54087bc5a9c68a181 (diff)
downloadmtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.zip
mtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.tar.gz
mtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.tar.bz2
lots of small package changes and dependency cleanups for the V= stuff
SVN-Revision: 2230
Diffstat (limited to 'openwrt/package/bluez-libs')
-rw-r--r--openwrt/package/bluez-libs/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/bluez-libs/Makefile b/openwrt/package/bluez-libs/Makefile
index 17ac5a1..7490fa8 100644
--- a/openwrt/package/bluez-libs/Makefile
+++ b/openwrt/package/bluez-libs/Makefile
@@ -22,7 +22,7 @@ $(PKG_BUILD_DIR)/.source: $(DL_DIR)/$(PKG_SOURCE)
zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
touch $(BLUEZLIBS_DIR)/.source
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
@@ -58,7 +58,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
)
touch $@
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
@@ -84,5 +84,5 @@ uninstall-dev:
rm -rf $(STAGING_DIR)/usr/include/bluetooth
rm -rf $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*}
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev