summaryrefslogtreecommitdiff
path: root/openwrt/package/bluez-libs
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-10 16:06:24 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-10 16:06:24 +0000
commit4eb17c54154a9f89d4aeb097bbc17eabf6475443 (patch)
tree8d5d1cb1834673f54bf26163e53efd692657d167 /openwrt/package/bluez-libs
parent2cb724bb3670625ba8cfce342dd40990edad62ee (diff)
downloadmtk-20170518-4eb17c54154a9f89d4aeb097bbc17eabf6475443.zip
mtk-20170518-4eb17c54154a9f89d4aeb097bbc17eabf6475443.tar.gz
mtk-20170518-4eb17c54154a9f89d4aeb097bbc17eabf6475443.tar.bz2
Fix building when host and target systems are same arch
SVN-Revision: 1597
Diffstat (limited to 'openwrt/package/bluez-libs')
-rw-r--r--openwrt/package/bluez-libs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/openwrt/package/bluez-libs/Makefile b/openwrt/package/bluez-libs/Makefile
index 6a65590..17ac5a1 100644
--- a/openwrt/package/bluez-libs/Makefile
+++ b/openwrt/package/bluez-libs/Makefile
@@ -27,7 +27,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
./configure \
@@ -81,6 +81,7 @@ $(STAGING_DIR)/usr/lib/libbluetooth.so: $(PKG_BUILD_DIR)/.built
install-dev: $(STAGING_DIR)/usr/lib/libbluetooth.so
uninstall-dev:
+ rm -rf $(STAGING_DIR)/usr/include/bluetooth
rm -rf $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*}
compile: install-dev