summaryrefslogtreecommitdiff
path: root/openwrt/package/bridge
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-04-21 09:55:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-04-21 09:55:30 +0000
commit5606b2216603d2539af73cf2b23f1bfaa2212490 (patch)
tree876aaafddc7b483732de04ec52283f20445eb181 /openwrt/package/bridge
parentebb58643eb864c2d26c2a47fbf87ee96a8580495 (diff)
downloadmtk-20170518-5606b2216603d2539af73cf2b23f1bfaa2212490.zip
mtk-20170518-5606b2216603d2539af73cf2b23f1bfaa2212490.tar.gz
mtk-20170518-5606b2216603d2539af73cf2b23f1bfaa2212490.tar.bz2
fix bridge build and description, add default configure command to rules.mk, use CONFIG_ as prefix for package selction variables
SVN-Revision: 3690
Diffstat (limited to 'openwrt/package/bridge')
-rw-r--r--openwrt/package/bridge/Makefile24
1 files changed, 3 insertions, 21 deletions
diff --git a/openwrt/package/bridge/Makefile b/openwrt/package/bridge/Makefile
index be52b2a..18ea1dd 100644
--- a/openwrt/package/bridge/Makefile
+++ b/openwrt/package/bridge/Makefile
@@ -19,36 +19,18 @@ SECTION:=base
CATEGORY:=Network
DEFAULT:=y
TITLE:=Ethernet bridging configuration utility
-DESCRIPTION:=Manage ethernet bridging; a way to connect networks together to\\\
+DESCRIPTION:=Ethernet bridging configuration utility\\\
+Manage ethernet bridging; a way to connect networks together to\\\
form a larger network.
URL:=http://bridge.sourceforge.net/
endef
define Build/Configure
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- --with-linux-headers=$(LINUX_DIR)
+$(call Build/Configure/Default,--with-linux-headers=$(LINUX_DIR))
endef
-
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)
- touch $@
endef
define Package/busybox/install