summaryrefslogtreecommitdiff
path: root/openwrt/package/chillispot/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
commit48e69e6e71ed8e65a119ced3bf7b9f496dcc8385 (patch)
treeb8351969b1dadbaabafe43482b81fc9ec7aaabaa /openwrt/package/chillispot/Makefile
parent5bba199dd0e5dcb544e30137be239206278a2024 (diff)
downloadmtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.zip
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.gz
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.bz2
Tweak package build
SVN-Revision: 968
Diffstat (limited to 'openwrt/package/chillispot/Makefile')
-rw-r--r--openwrt/package/chillispot/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/openwrt/package/chillispot/Makefile b/openwrt/package/chillispot/Makefile
index cacaee2..81937aa 100644
--- a/openwrt/package/chillispot/Makefile
+++ b/openwrt/package/chillispot/Makefile
@@ -50,14 +50,14 @@ $(PKG_BUILD_DIR)/.configured:
);
touch $@
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS)
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_CHILLISPOT):
install -m0755 -d $(IDIR_CHILLISPOT)/etc/init.d