summaryrefslogtreecommitdiff
path: root/openwrt/package/cifsmount
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 23:12:35 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 23:12:35 +0000
commita5ec491a09d7181d85d564d1db560587b84876f9 (patch)
treeb7b32bf02c07b6e08eaf74a539aa48c41f8a6064 /openwrt/package/cifsmount
parentc519093d573fe3f1143271ee3f98941f871891e9 (diff)
downloadmtk-20170518-a5ec491a09d7181d85d564d1db560587b84876f9.zip
mtk-20170518-a5ec491a09d7181d85d564d1db560587b84876f9.tar.gz
mtk-20170518-a5ec491a09d7181d85d564d1db560587b84876f9.tar.bz2
Use TARGET_CFLAGS, strip at package time
SVN-Revision: 983
Diffstat (limited to 'openwrt/package/cifsmount')
-rw-r--r--openwrt/package/cifsmount/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/cifsmount/Makefile b/openwrt/package/cifsmount/Makefile
index d0d186a..2cb64d4 100644
--- a/openwrt/package/cifsmount/Makefile
+++ b/openwrt/package/cifsmount/Makefile
@@ -20,11 +20,11 @@ $(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(TARGET_CC) -o $(PKG_BUILD_DIR)/mount.cifs mount.cifs.c
- $(STRIP) $(PKG_BUILD_DIR)/mount.cifs
+ $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mount.cifs mount.cifs.c
touch $@
$(IPKG_CIFSMOUNT):
- mkdir -p $(IDIR_CIFSMOUNT)/sbin
- install -m 0755 $(PKG_BUILD_DIR)/mount.cifs $(IDIR_CIFSMOUNT)/sbin/mount.cifs
+ install -d -m0755 $(IDIR_CIFSMOUNT)/sbin
+ install -m0755 $(PKG_BUILD_DIR)/mount.cifs $(IDIR_CIFSMOUNT)/sbin/
+ $(RSTRIP) $(IDIR_CIFSMOUNT)
$(IPKG_BUILD) $(IDIR_CIFSMOUNT) $(PACKAGE_DIR)