summaryrefslogtreecommitdiff
path: root/openwrt/package/dropbear
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-03-06 12:03:54 +0000
committerNicolas Thill <nico@openwrt.org>2005-03-06 12:03:54 +0000
commit234b39a199c12c69fd68680e7057e73326fc2cb4 (patch)
treea0d55a1af9452553547e40d42830c4669d9943d3 /openwrt/package/dropbear
parent77ac9d2c485b05517f86e01d8bf210d8bb957ed7 (diff)
downloadmtk-20170518-234b39a199c12c69fd68680e7057e73326fc2cb4.zip
mtk-20170518-234b39a199c12c69fd68680e7057e73326fc2cb4.tar.gz
mtk-20170518-234b39a199c12c69fd68680e7057e73326fc2cb4.tar.bz2
Add package install dependencies (don't install a package if it's already installed)
SVN-Revision: 315
Diffstat (limited to 'openwrt/package/dropbear')
-rw-r--r--openwrt/package/dropbear/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/openwrt/package/dropbear/Makefile b/openwrt/package/dropbear/Makefile
index eec889d..62d802e 100644
--- a/openwrt/package/dropbear/Makefile
+++ b/openwrt/package/dropbear/Makefile
@@ -69,11 +69,14 @@ $(PACKAGE_DIR)/$(DROPBEAR_IPK): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
chmod a+x $(DROPBEAR_IPK_DIR)/etc/init.d/S50dropbear
$(IPKG_BUILD) $(DROPBEAR_IPK_DIR) $(PACKAGE_DIR)
+$(IPKG_STATE_DIR)/info/dropbear.list: $(PACKAGE_DIR)/$(DROPBEAR_IPK)
+ $(IPKG) install $(PACKAGE_DIR)/$(DROPBEAR_IPK)
+
source: $(DL_DIR)/$(DROPBEAR_SOURCE)
prepare: $(DROPBEAR_DIR)/.patched
compile: $(PACKAGE_DIR)/$(DROPBEAR_IPK)
-install: compile
- $(IPKG) install $(PACKAGE_DIR)/$(DROPBEAR_IPK)
+install: $(IPKG_STATE_DIR)/info/dropbear.list
+
clean:
rm -rf $(DROPBEAR_DIR)
rm -f $(PACKAGE_DIR)/$(DROPBEAR_IPK)