summaryrefslogtreecommitdiff
path: root/openwrt/package/ebtables
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-05-21 11:51:56 +0000
committerNicolas Thill <nico@openwrt.org>2006-05-21 11:51:56 +0000
commit86f764dfb7f82da97ade12b943a57d94609164cf (patch)
treeef726476faf587fab06192b6021e3115edf46f81 /openwrt/package/ebtables
parentde34f4febbde95921d4521b9932dc30a73e644f1 (diff)
downloadmtk-20170518-86f764dfb7f82da97ade12b943a57d94609164cf.zip
mtk-20170518-86f764dfb7f82da97ade12b943a57d94609164cf.tar.gz
mtk-20170518-86f764dfb7f82da97ade12b943a57d94609164cf.tar.bz2
tweak ebtables package: * add /etc/ethertypes (closes: #560), * strip, standardize, * bump release number.
SVN-Revision: 3811
Diffstat (limited to 'openwrt/package/ebtables')
-rw-r--r--openwrt/package/ebtables/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index 9abd93a..d9c1c99 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -4,14 +4,15 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
PKG_VERSION:=2.0.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=c4559af2366c764c6c42a3fdd40d60d3
PKG_SOURCE_URL:=@SF/ebtables
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
PKG_CAT:=zcat
+PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
+
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,EBTABLES,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -26,7 +27,9 @@ $(PKG_BUILD_DIR)/.built:
touch $@
$(IPKG_EBTABLES):
- mkdir -p $(IDIR_EBTABLES)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+ install -d -m0755 $(IDIR_EBTABLES)/etc
+ install -m0644 $(PKG_BUILD_DIR)/ethertypes $(IDIR_EBTABLES)/etc/
+ install -d -m0755 $(IDIR_EBTABLES)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+ $(RSTRIP) $(IDIR_EBTABLES)
$(IPKG_BUILD) $(IDIR_EBTABLES) $(PACKAGE_DIR)
-