summaryrefslogtreecommitdiff
path: root/openwrt/package/expat/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-14 04:24:44 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-14 04:24:44 +0000
commitfd742beb74ed96b8f0a87e6a20ca73e639a90fb9 (patch)
tree6bc1e3b2c02726f41b55b5c29e5f04d98fe5a067 /openwrt/package/expat/patches
parentda32248a24d437ab6c8cf088454b2fd4c56d1a20 (diff)
downloadmtk-20170518-fd742beb74ed96b8f0a87e6a20ca73e639a90fb9.zip
mtk-20170518-fd742beb74ed96b8f0a87e6a20ca73e639a90fb9.tar.gz
mtk-20170518-fd742beb74ed96b8f0a87e6a20ca73e639a90fb9.tar.bz2
add expat package
SVN-Revision: 1656
Diffstat (limited to 'openwrt/package/expat/patches')
-rw-r--r--openwrt/package/expat/patches/001-destdir.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/openwrt/package/expat/patches/001-destdir.patch b/openwrt/package/expat/patches/001-destdir.patch
new file mode 100644
index 0000000..dc1f36a
--- /dev/null
+++ b/openwrt/package/expat/patches/001-destdir.patch
@@ -0,0 +1,44 @@
+diff -ruN expat-1.95.8-orig/Makefile.in expat-1.95.8-1/Makefile.in
+--- expat-1.95.8-orig/Makefile.in 2004-05-07 22:00:48.000000000 +0200
++++ expat-1.95.8-1/Makefile.in 2005-04-04 22:53:09.000000000 +0200
+@@ -34,6 +34,8 @@
+
+ top_builddir = .
+
++DESTDIR =
++
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+@@ -73,22 +75,22 @@
+ tests/runtests
+
+ install: xmlwf/xmlwf installlib
+- $(mkinstalldirs) $(bindir) $(man1dir)
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(bindir)/xmlwf
+- $(INSTALL_DATA) $(MANFILE) $(man1dir)
++ $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
++ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(DESTDIR)$(bindir)/xmlwf
++ $(INSTALL_DATA) $(MANFILE) $(DESTDIR)$(man1dir)
+
+ installlib: $(LIBRARY) $(APIHEADER)
+- $(mkinstalldirs) $(libdir) $(includedir)
+- $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(libdir)/$(LIBRARY)
+- $(INSTALL_DATA) $(APIHEADER) $(includedir)
++ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
++ $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(DESTDIR)$(libdir)/$(LIBRARY)
++ $(INSTALL_DATA) $(APIHEADER) $(DESTDIR)$(includedir)
+
+ uninstall: uninstalllib
+- $(LIBTOOL) --mode=uninstall rm -f $(bindir)/xmlwf
++ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(bindir)/xmlwf
+ rm -f $(man1dir)/xmlwf.1
+
+ uninstalllib:
+- $(LIBTOOL) --mode=uninstall rm -f $(libdir)/$(LIBRARY)
+- rm -f $(includedir)/$(APIHEADER)
++ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(libdir)/$(LIBRARY)
++ rm -f $(DESTDIR)$(includedir)/$(APIHEADER)
+
+ # for VPATH builds (invoked by configure)
+ mkdir-init: