summaryrefslogtreecommitdiff
path: root/openwrt/package/ez-ipupdate
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-02-08 14:08:21 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-02-08 14:08:21 +0000
commitb2515858d97244e06bd234fd97e4ec2b10f520a8 (patch)
treed4c26326eb97910fe89f00465cd04b009c54cba7 /openwrt/package/ez-ipupdate
parent3a805b3c51ba6db6472c200d61f89487b527a6b1 (diff)
downloadmtk-20170518-b2515858d97244e06bd234fd97e4ec2b10f520a8.zip
mtk-20170518-b2515858d97244e06bd234fd97e4ec2b10f520a8.tar.gz
mtk-20170518-b2515858d97244e06bd234fd97e4ec2b10f520a8.tar.bz2
Removed init script as there is an hotplug one, check whether user configuration directive is properly set, change the numbering to 10 rather than 15
SVN-Revision: 3189
Diffstat (limited to 'openwrt/package/ez-ipupdate')
-rw-r--r--openwrt/package/ez-ipupdate/Makefile2
-rw-r--r--openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug7
2 files changed, 7 insertions, 2 deletions
diff --git a/openwrt/package/ez-ipupdate/Makefile b/openwrt/package/ez-ipupdate/Makefile
index 66a25d9..ce2583a 100644
--- a/openwrt/package/ez-ipupdate/Makefile
+++ b/openwrt/package/ez-ipupdate/Makefile
@@ -50,7 +50,7 @@ $(IPKG_EZIPUPDATE):
install -m0755 $(PKG_BUILD_DIR)/ez-ipupdate $(IDIR_EZIPUPDATE)/usr/sbin/
install -m0755 files/$(PKG_NAME).init $(IDIR_EZIPUPDATE)/etc/init.d/S80$(PKG_NAME)
install -m0755 files/$(PKG_NAME).conf $(IDIR_EZIPUPDATE)/etc/
- install -m0755 files/$(PKG_NAME).hotplug $(IDIR_EZIPUPDATE)/etc/hotplug.d/iface/15-$(PKG_NAME)
+ install -m0755 files/$(PKG_NAME).hotplug $(IDIR_EZIPUPDATE)/etc/hotplug.d/iface/10-$(PKG_NAME)
$(STRIP) $(IDIR_EZIPUPDATE)/usr/sbin/*
$(IPKG_BUILD) $(IDIR_EZIPUPDATE) $(PACKAGE_DIR)
diff --git a/openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug b/openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug
index 3f27c14..56a054b 100644
--- a/openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug
+++ b/openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug
@@ -1 +1,6 @@
-[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && /usr/sbin/ez-ipupdate -c /etc/ez-ipupdate.conf &
+PGM=ez-ipupdate
+[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && {
+ [ -e /etc/$PGM.conf ] && {
+ [ -n $(grep "user=" /etc/$PGM.conf | cut -d= -f2 | cut -d: -f1) ] && [ -n $(grep "user=" /etc/$PGM.conf | cut -d= -f2 | cut -d: -f2) ] && /usr/sbin/$PGM -c /etc/$PGM.conf &
+ }
+}