summaryrefslogtreecommitdiff
path: root/openwrt/package/fetchmail
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2006-03-15 16:52:29 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2006-03-15 16:52:29 +0000
commit32f1da72e84c12e1affdff26a5e48a34cbbb4b0e (patch)
tree0cccc584cc23d1ca034f5fbededfcd47b5d3e640 /openwrt/package/fetchmail
parent8c80efabd4c74477ec222df669c61f65351110c5 (diff)
downloadmtk-20170518-32f1da72e84c12e1affdff26a5e48a34cbbb4b0e.zip
mtk-20170518-32f1da72e84c12e1affdff26a5e48a34cbbb4b0e.tar.gz
mtk-20170518-32f1da72e84c12e1affdff26a5e48a34cbbb4b0e.tar.bz2
add elinks, mutt, fetchmail and procmail, thx Michael Cohen, procmail disabled, compile problem
SVN-Revision: 3379
Diffstat (limited to 'openwrt/package/fetchmail')
-rw-r--r--openwrt/package/fetchmail/Config.in8
-rw-r--r--openwrt/package/fetchmail/Makefile59
-rw-r--r--openwrt/package/fetchmail/ipkg/fetchmail.control5
3 files changed, 72 insertions, 0 deletions
diff --git a/openwrt/package/fetchmail/Config.in b/openwrt/package/fetchmail/Config.in
new file mode 100644
index 0000000..bc6cdfe
--- /dev/null
+++ b/openwrt/package/fetchmail/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_FETCHMAIL
+ prompt "fetchmail......................... Remote mail retriever"
+ tristate
+ default m if CONFIG_DEVEL
+ help
+ Retrieves remote mail via POP/IMAP
+
+ Very useful in conjunction with mutt.
diff --git a/openwrt/package/fetchmail/Makefile b/openwrt/package/fetchmail/Makefile
new file mode 100644
index 0000000..1ca6cd7
--- /dev/null
+++ b/openwrt/package/fetchmail/Makefile
@@ -0,0 +1,59 @@
+# $Id: Makefile 3112 2006-02-01 23:53:19Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fetchmail
+PKG_VERSION:=6.2.5
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,FETCHMAIL,fetchmail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ ac_cv_c_bigendian=no \
+ ac_cv_sizeof_off_t=8 \
+ ac_cv_sizeof_int=4 \
+ ac_cv_sizeof_long=4 \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --program-prefix="" \
+ --enable-fallback=procmail \
+ $(DISABLE_NLS) \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC)
+ touch $@
+
+$(IPKG_FETCHMAIL):
+ mkdir -p $(IDIR_FETCHMAIL)/usr/bin
+ $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_FETCHMAIL)/usr/bin/
+ $(RSTRIP) $(IDIR_FETCHMAIL)
+ $(IPKG_BUILD) $(IDIR_FETCHMAIL) $(PACKAGE_DIR)
diff --git a/openwrt/package/fetchmail/ipkg/fetchmail.control b/openwrt/package/fetchmail/ipkg/fetchmail.control
new file mode 100644
index 0000000..ea664fa
--- /dev/null
+++ b/openwrt/package/fetchmail/ipkg/fetchmail.control
@@ -0,0 +1,5 @@
+Package: fetchmail
+Priority: optional
+Section: text
+Depends:
+Description: Mail text client