summaryrefslogtreecommitdiff
path: root/openwrt/package/fuse/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
commit48e69e6e71ed8e65a119ced3bf7b9f496dcc8385 (patch)
treeb8351969b1dadbaabafe43482b81fc9ec7aaabaa /openwrt/package/fuse/Makefile
parent5bba199dd0e5dcb544e30137be239206278a2024 (diff)
downloadmtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.zip
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.gz
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.bz2
Tweak package build
SVN-Revision: 968
Diffstat (limited to 'openwrt/package/fuse/Makefile')
-rw-r--r--openwrt/package/fuse/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/fuse/Makefile b/openwrt/package/fuse/Makefile
index 4e228b3..9ddd2ab 100644
--- a/openwrt/package/fuse/Makefile
+++ b/openwrt/package/fuse/Makefile
@@ -59,15 +59,15 @@ $(PKG_BUILD_DIR)/.configured:
--disable-auto-modprobe \
--with-kernel=$(LINUX_DIR) \
);
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR)
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_KMOD_FUSE):
mkdir -p $(IDIR_KMOD_FUSE)/lib/modules/$(LINUX_VERSION)