summaryrefslogtreecommitdiff
path: root/openwrt/package/fuse
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
commit269c7158041cbb548a602b9e17e8ee7779aeb44d (patch)
tree823ff43388135467a5c7a60589acf62d173cedc4 /openwrt/package/fuse
parentca55f8d3da7f00f440f0b21d88b397f4c9554f73 (diff)
downloadmtk-20170518-269c7158041cbb548a602b9e17e8ee7779aeb44d.zip
mtk-20170518-269c7158041cbb548a602b9e17e8ee7779aeb44d.tar.gz
mtk-20170518-269c7158041cbb548a602b9e17e8ee7779aeb44d.tar.bz2
move package/linux into target/linux, use wbx' new kernel code. support building images with more than one kernel, split kernel module parts off of packages that use their own kernel modules (fuse, shfs, openswan). some cleanup in the image building process in target/. image builder is disabled for now, needs some fixing.
SVN-Revision: 1085
Diffstat (limited to 'openwrt/package/fuse')
-rw-r--r--openwrt/package/fuse/Config.in29
-rw-r--r--openwrt/package/fuse/Makefile7
-rw-r--r--openwrt/package/fuse/ipkg/kmod-fuse.control8
3 files changed, 2 insertions, 42 deletions
diff --git a/openwrt/package/fuse/Config.in b/openwrt/package/fuse/Config.in
index 92852bf..5159140 100644
--- a/openwrt/package/fuse/Config.in
+++ b/openwrt/package/fuse/Config.in
@@ -1,39 +1,14 @@
config BR2_PACKAGE_FUSE
bool
default n
- depends BR2_PACKAGE_KMOD_FUSE
+ depends BR2_PACKAGE_LIBFUSE
-config BR2_PACKAGE_KMOD_FUSE
- select BR2_PACKAGE_FUSE
- prompt "kmod-fuse - FUSE kernel module"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_FUSE
- help
- With FUSE it is possible to implement a fully functional
- filesystem in a userspace program.
-
- Features include:
-
- * Simple library API
- * Simple installation (no need to patch or recompile the kernel)
- * Secure implementation
- * Userspace - kernel interface is very efficient
- * Usable by non privileged users
- * Runs on Linux kernels 2.4.X and 2.6.X
- * Has proven very stable over time
-
-
- http://fuse.sourceforge.net/
-
- This package contains the fuse.o kernel module.
-
config BR2_PACKAGE_LIBFUSE
prompt "libfuse - FUSE library"
tristate
default m if CONFIG_DEVEL
- depends BR2_PACKAGE_KMOD_FUSE
+ select BR2_PACKAGE_KMOD_FUSE
select BR2_PACKAGE_LIBPTHREAD
help
With FUSE it is possible to implement a fully functional
diff --git a/openwrt/package/fuse/Makefile b/openwrt/package/fuse/Makefile
index 869689f..60fb4be 100644
--- a/openwrt/package/fuse/Makefile
+++ b/openwrt/package/fuse/Makefile
@@ -16,7 +16,6 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,KMOD_FUSE,kmod-fuse,$(LINUX_VERSION)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIBFUSE,libfuse,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,FUSE_UTILS,fuse-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -69,12 +68,6 @@ $(PKG_BUILD_DIR)/.built:
all install
touch $@
-$(IPKG_KMOD_FUSE):
- mkdir -p $(IDIR_KMOD_FUSE)/lib/modules/$(LINUX_VERSION)
- cp -fpR $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.o \
- $(IDIR_KMOD_FUSE)/lib/modules/$(LINUX_VERSION)/
- $(IPKG_BUILD) $(IDIR_KMOD_FUSE) $(PACKAGE_DIR)
-
$(IPKG_LIBFUSE):
mkdir -p $(IDIR_LIBFUSE)/usr/lib
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libfuse.so.* $(IDIR_LIBFUSE)/usr/lib/
diff --git a/openwrt/package/fuse/ipkg/kmod-fuse.control b/openwrt/package/fuse/ipkg/kmod-fuse.control
deleted file mode 100644
index 9d2e919..0000000
--- a/openwrt/package/fuse/ipkg/kmod-fuse.control
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: kmod-fuse
-Priority: optional
-Section: kernel
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/fuse2/
-Description: Filesystem in Userspace (kernel module)