summaryrefslogtreecommitdiff
path: root/openwrt/package/gpsd
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-23 01:29:01 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-23 01:29:01 +0000
commit650cb6dc83eb1cc7d429ea9e557ebc857f5c9387 (patch)
tree4a9c268cf4e8d0b68f5ac5fd9bb5cf2489872dd3 /openwrt/package/gpsd
parent48bd032248fdc8781442e370b384070b1767a7ef (diff)
downloadmtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.zip
mtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.tar.gz
mtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.tar.bz2
build c++ sources without rtti
SVN-Revision: 2271
Diffstat (limited to 'openwrt/package/gpsd')
-rw-r--r--openwrt/package/gpsd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/gpsd/Makefile b/openwrt/package/gpsd/Makefile
index 2161fb7..43fad85 100644
--- a/openwrt/package/gpsd/Makefile
+++ b/openwrt/package/gpsd/Makefile
@@ -22,10 +22,10 @@ $(PKG_BUILD_DIR)/.configured:
( cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -nostdinc++" \
+ CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- LIBS="-nodefaultlibs -luClibc++ -lc -lm -lnotimpl" \
+ LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ LIBS="-luClibc++ -lc -lm -lnotimpl" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \