summaryrefslogtreecommitdiff
path: root/openwrt/package/id3lib/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-23 01:29:01 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-23 01:29:01 +0000
commit650cb6dc83eb1cc7d429ea9e557ebc857f5c9387 (patch)
tree4a9c268cf4e8d0b68f5ac5fd9bb5cf2489872dd3 /openwrt/package/id3lib/Makefile
parent48bd032248fdc8781442e370b384070b1767a7ef (diff)
downloadmtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.zip
mtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.tar.gz
mtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.tar.bz2
build c++ sources without rtti
SVN-Revision: 2271
Diffstat (limited to 'openwrt/package/id3lib/Makefile')
-rw-r--r--openwrt/package/id3lib/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/package/id3lib/Makefile b/openwrt/package/id3lib/Makefile
index 7d2924a..c40d800 100644
--- a/openwrt/package/id3lib/Makefile
+++ b/openwrt/package/id3lib/Makefile
@@ -22,7 +22,7 @@ $(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin" \
+ CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(LINUX_DIR)/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
LIBS="-Wl,-Bdynamic,-luClibc++,-Bstatic,-lstdc++,-Bdynamic,-lz,-lm,-lc" \