summaryrefslogtreecommitdiff
path: root/openwrt/package/iptables
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 13:00:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 13:00:11 +0000
commit579b222d5e4911e2028981d4a9b20d41b693d1d6 (patch)
tree40cd199b16cc78373fa61285af30c8c39881c297 /openwrt/package/iptables
parent61c868f34fa3efd1794579b986d130fe4ce4c972 (diff)
downloadmtk-20170518-579b222d5e4911e2028981d4a9b20d41b693d1d6.zip
mtk-20170518-579b222d5e4911e2028981d4a9b20d41b693d1d6.tar.gz
mtk-20170518-579b222d5e4911e2028981d4a9b20d41b693d1d6.tar.bz2
add missing BuildPackage lines, convert install-dev: to Build/InstallDev
SVN-Revision: 3857
Diffstat (limited to 'openwrt/package/iptables')
-rw-r--r--openwrt/package/iptables/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index ae2adcf..4c547be 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -162,6 +162,22 @@ define Build/Compile
DESTDIR="$(PKG_INSTALL_DIR)" \
all install install-devel
endef
+
+
+define Build/InstallDev
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
+ KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
+ DESTDIR="$(STAGING_DIR)" \
+ install install-devel
+endef
+
+define Build/UninstallDev
+ rm -rf $(STAGING_DIR)/usr/include/libipq.h
+ rm -rf $(STAGING_DIR)/usr/lib/libipq.a
+endef
+
define Package/iptables/install
install -d -m0755 $(1)/etc/config
@@ -223,21 +239,3 @@ $(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
$(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPackage,ip6tables))
-
-
-$(STAGING_DIR)/usr/lib/libipq.a: $(PKG_BUILD_DIR)/.built
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
- KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
- DESTDIR="$(STAGING_DIR)" \
- install install-devel
-
-install-dev: $(STAGING_DIR)/usr/lib/libipq.a
-uninstall-dev:
- rm -rf $(STAGING_DIR)/usr/include/libipq.h
- rm -rf $(STAGING_DIR)/usr/lib/libipq.a
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
-