summaryrefslogtreecommitdiff
path: root/openwrt/package/libcli/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2005-12-14 13:23:40 +0000
committerFlorian Fainelli <florian@openwrt.org>2005-12-14 13:23:40 +0000
commit58fb874180d1eacb6d850b1dbe3ab1901a2aabc6 (patch)
tree7610224c7982bdf64f688024b2fe7c897e6b9c70 /openwrt/package/libcli/Makefile
parentdb75840d96c233a8972a521d7996052c3e2d7b8c (diff)
downloadmtk-20170518-58fb874180d1eacb6d850b1dbe3ab1901a2aabc6.zip
mtk-20170518-58fb874180d1eacb6d850b1dbe3ab1901a2aabc6.tar.gz
mtk-20170518-58fb874180d1eacb6d850b1dbe3ab1901a2aabc6.tar.bz2
Added libcli, l2tpns, fixed typo and mising URL
SVN-Revision: 2669
Diffstat (limited to 'openwrt/package/libcli/Makefile')
-rwxr-xr-xopenwrt/package/libcli/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/openwrt/package/libcli/Makefile b/openwrt/package/libcli/Makefile
new file mode 100755
index 0000000..795a8bd
--- /dev/null
+++ b/openwrt/package/libcli/Makefile
@@ -0,0 +1,30 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libcli
+PKG_VERSION:=1.8.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=0fdd30df5a8c1388a4549751ba61247a
+PKG_SOURCE_URL:=@SF/libcli
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBCLI,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CC) DESTDIR=$(STAGING_DIR) -C $(PKG_BUILD_DIR) install
+ $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+ touch $@
+
+$(IPKG_LIBCLI):
+ mkdir -p $(IDIR_LIBCLI)
+ cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_LIBCLI)/
+ $(RSTRIP) $(IDIR_LIBCLI)
+ $(IPKG_BUILD) $(IDIR_LIBCLI) $(PACKAGE_DIR)