summaryrefslogtreecommitdiff
path: root/openwrt/package/libelf/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-18 06:34:57 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-18 06:34:57 +0000
commitb694678b7489c300252cb2dc4572ddb83f1d90a3 (patch)
treee6ebdb7b1ef3288be5c8d868847974350beaf317 /openwrt/package/libelf/Makefile
parent7710ca63b917c78e34073e47e94f21a68e8fed14 (diff)
downloadmtk-20170518-b694678b7489c300252cb2dc4572ddb83f1d90a3.zip
mtk-20170518-b694678b7489c300252cb2dc4572ddb83f1d90a3.tar.gz
mtk-20170518-b694678b7489c300252cb2dc4572ddb83f1d90a3.tar.bz2
Uniformize package Makefile, move ipkg related files to ./ipkg
SVN-Revision: 665
Diffstat (limited to 'openwrt/package/libelf/Makefile')
-rw-r--r--openwrt/package/libelf/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/libelf/Makefile b/openwrt/package/libelf/Makefile
index c176db5..1357966 100644
--- a/openwrt/package/libelf/Makefile
+++ b/openwrt/package/libelf/Makefile
@@ -72,9 +72,9 @@ $(STAGING_DIR)/usr/lib/libelf.so: $(PKG_BUILD_DIR)/.built
install
$(IPKG_LIBELF): $(STAGING_DIR)/usr/lib/libelf.so
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBELF) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBELF) ./ipkg/$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(IDIR_LIBELF)/usr/lib
- cp -fp $(PKG_BUILD_DIR)/lib/libelf.so.* $(IDIR_LIBELF)/usr/lib/
+ cp -fpR $(PKG_BUILD_DIR)/lib/libelf.so.* $(IDIR_LIBELF)/usr/lib/
$(STRIP) $(IDIR_LIBELF)/usr/lib/lib*.so*
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(IDIR_LIBELF) $(PACKAGE_DIR)