summaryrefslogtreecommitdiff
path: root/openwrt/package/libelf/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
commit48e69e6e71ed8e65a119ced3bf7b9f496dcc8385 (patch)
treeb8351969b1dadbaabafe43482b81fc9ec7aaabaa /openwrt/package/libelf/Makefile
parent5bba199dd0e5dcb544e30137be239206278a2024 (diff)
downloadmtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.zip
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.gz
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.bz2
Tweak package build
SVN-Revision: 968
Diffstat (limited to 'openwrt/package/libelf/Makefile')
-rw-r--r--openwrt/package/libelf/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/openwrt/package/libelf/Makefile b/openwrt/package/libelf/Makefile
index 4e82c31..537c468 100644
--- a/openwrt/package/libelf/Makefile
+++ b/openwrt/package/libelf/Makefile
@@ -50,16 +50,16 @@ $(PKG_BUILD_DIR)/.configured:
--enable-shared \
--enable-static \
);
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
- CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld ARCH=$(ARCH)
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) -j1 \
+ CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld ARCH=$(ARCH) \
instroot="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_LIBELF):
install -d -m0755 $(IDIR_LIBELF)/usr/lib