summaryrefslogtreecommitdiff
path: root/openwrt/package/libnet/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-18 06:34:57 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-18 06:34:57 +0000
commitb694678b7489c300252cb2dc4572ddb83f1d90a3 (patch)
treee6ebdb7b1ef3288be5c8d868847974350beaf317 /openwrt/package/libnet/Makefile
parent7710ca63b917c78e34073e47e94f21a68e8fed14 (diff)
downloadmtk-20170518-b694678b7489c300252cb2dc4572ddb83f1d90a3.zip
mtk-20170518-b694678b7489c300252cb2dc4572ddb83f1d90a3.tar.gz
mtk-20170518-b694678b7489c300252cb2dc4572ddb83f1d90a3.tar.bz2
Uniformize package Makefile, move ipkg related files to ./ipkg
SVN-Revision: 665
Diffstat (limited to 'openwrt/package/libnet/Makefile')
-rw-r--r--openwrt/package/libnet/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/libnet/Makefile b/openwrt/package/libnet/Makefile
index ba5e777..79b8960 100644
--- a/openwrt/package/libnet/Makefile
+++ b/openwrt/package/libnet/Makefile
@@ -80,9 +80,9 @@ $(STAGING_DIR)/usr/lib/libnet.so: $(PKG_BUILD_DIR)/.built
rm -rf $(STAGING_DIR)/usr/lib/libnet.la
$(IPKG_LIBNET): $(STAGING_DIR)/usr/lib/libnet.so
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBNET) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBNET) ./ipkg/$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(IDIR_LIBNET)/usr/lib
- cp -fp $(STAGING_DIR)/usr/lib/libnet.so.* $(IDIR_LIBNET)/usr/lib/
+ cp -fpR $(STAGING_DIR)/usr/lib/libnet.so.* $(IDIR_LIBNET)/usr/lib/
$(STRIP) $(IDIR_LIBNET)/usr/lib/lib*.so*
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(IDIR_LIBNET) $(PACKAGE_DIR)