summaryrefslogtreecommitdiff
path: root/openwrt/package/libnet
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
commit48e69e6e71ed8e65a119ced3bf7b9f496dcc8385 (patch)
treeb8351969b1dadbaabafe43482b81fc9ec7aaabaa /openwrt/package/libnet
parent5bba199dd0e5dcb544e30137be239206278a2024 (diff)
downloadmtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.zip
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.gz
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.bz2
Tweak package build
SVN-Revision: 968
Diffstat (limited to 'openwrt/package/libnet')
-rw-r--r--openwrt/package/libnet/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/openwrt/package/libnet/Makefile b/openwrt/package/libnet/Makefile
index f628f1b..75aa248 100644
--- a/openwrt/package/libnet/Makefile
+++ b/openwrt/package/libnet/Makefile
@@ -7,9 +7,7 @@ PKG_VERSION:=1.0.2a
PKG_RELEASE:=7
PKG_MD5SUM:=ddf53f0f484184390e8c2a1bd0853667
-PKG_SOURCE_URL:=\
- http://www.packetfactory.net/libnet/dist/deprecated/ \
- http://nthill.free.fr/openwrt/sources/$(PKG_NAME)/
+PKG_SOURCE_URL:=http://www.packetfactory.net/libnet/dist/deprecated/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
@@ -58,17 +56,17 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--enable-static \
--with-pf_packet=yes \
);
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)"
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_LIBNET): $(STAGING_DIR)/usr/lib/libnet.so
install -m0755 -d $(IDIR_LIBNET)/usr/lib