summaryrefslogtreecommitdiff
path: root/openwrt/package/libosip2/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
commit48e69e6e71ed8e65a119ced3bf7b9f496dcc8385 (patch)
treeb8351969b1dadbaabafe43482b81fc9ec7aaabaa /openwrt/package/libosip2/Makefile
parent5bba199dd0e5dcb544e30137be239206278a2024 (diff)
downloadmtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.zip
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.gz
mtk-20170518-48e69e6e71ed8e65a119ced3bf7b9f496dcc8385.tar.bz2
Tweak package build
SVN-Revision: 968
Diffstat (limited to 'openwrt/package/libosip2/Makefile')
-rw-r--r--openwrt/package/libosip2/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/libosip2/Makefile b/openwrt/package/libosip2/Makefile
index 2e7bb93..c0b0357 100644
--- a/openwrt/package/libosip2/Makefile
+++ b/openwrt/package/libosip2/Makefile
@@ -53,15 +53,15 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--enable-semaphore \
--enable-ntimer \
);
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -C $(PKG_BUILD_DIR)
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_LIBOSIP2):
install -m0755 -d $(IDIR_LIBOSIP2)/usr/lib