summaryrefslogtreecommitdiff
path: root/openwrt/package/linux
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-02-19 13:00:30 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-02-19 13:00:30 +0000
commitaad0c0841c56f866c73aa819d2af7b5596604fd9 (patch)
tree5ff9396a098d631bae3a7d7c70bd4d9fa294a8af /openwrt/package/linux
parent2572b0e67f54ccc9b50a9751ce80deb491344fd5 (diff)
downloadmtk-20170518-aad0c0841c56f866c73aa819d2af7b5596604fd9.zip
mtk-20170518-aad0c0841c56f866c73aa819d2af7b5596604fd9.tar.gz
mtk-20170518-aad0c0841c56f866c73aa819d2af7b5596604fd9.tar.bz2
demistifying make *clean targets, fix some clean targets issues
SVN-Revision: 272
Diffstat (limited to 'openwrt/package/linux')
-rw-r--r--openwrt/package/linux/linux.config2
-rw-r--r--openwrt/package/linux/linux.mk6
2 files changed, 7 insertions, 1 deletions
diff --git a/openwrt/package/linux/linux.config b/openwrt/package/linux/linux.config
index aef2c28..423fd8c 100644
--- a/openwrt/package/linux/linux.config
+++ b/openwrt/package/linux/linux.config
@@ -86,7 +86,7 @@ CONFIG_BCM4704=y
# CONFIG_HIGHMEM is not set
CONFIG_RWSEM_GENERIC_SPINLOCK=y
# CONFIG_RWSEM_XCHGADD_ALGORITHM is not set
-CONFIG_CMDLINE="root=/dev/mtdblock2 rootfstype=squashfs init=/etc/preinit noinitrd console=ttyS0,115200"
+CONFIG_CMDLINE="root=/dev/mtdblock2 rootfstype=jffs2 init=/etc/preinit noinitrd console=ttyS0,115200"
CONFIG_PCI=y
CONFIG_NONCOHERENT_IO=y
CONFIG_NEW_TIME_C=y
diff --git a/openwrt/package/linux/linux.mk b/openwrt/package/linux/linux.mk
index 6d4545b..bead222 100644
--- a/openwrt/package/linux/linux.mk
+++ b/openwrt/package/linux/linux.mk
@@ -57,6 +57,12 @@ endif
$(LINUX_DIR)/.configured: $(LINUX_DIR)/.patched
-cp $(LINUX_KCONFIG) $(LINUX_DIR)/.config
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_LZMA),y)
+ $(SED) "s,rootfstype=jffs2,rootfstype=squashfs," $(LINUX_DIR)/.config
+endif
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS),y)
+ $(SED) "s,rootfstype=jffs2,rootfstype=squashfs," $(LINUX_DIR)/.config
+endif
$(SED) "s,^CROSS_COMPILE.*,CROSS_COMPILE=$(KERNEL_CROSS),g;" $(LINUX_DIR)/Makefile
$(SED) "s,^CROSS_COMPILE.*,CROSS_COMPILE=$(KERNEL_CROSS),g;" $(LINUX_DIR)/arch/mips/Makefile
$(SED) "s,\-mcpu=,\-mtune=,g;" $(LINUX_DIR)/arch/mips/Makefile