summaryrefslogtreecommitdiff
path: root/openwrt/package/linux
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-03-09 22:55:13 +0000
committerNicolas Thill <nico@openwrt.org>2005-03-09 22:55:13 +0000
commitf32d3bc30e83079d353fe72e8f33dfa741bae292 (patch)
treee1c7e8dedbd8f3a9407c5025e5e501cdb5475aa2 /openwrt/package/linux
parent2489bff8c0ee47946e4051b23d65ce27e9857441 (diff)
downloadmtk-20170518-f32d3bc30e83079d353fe72e8f33dfa741bae292.zip
mtk-20170518-f32d3bc30e83079d353fe72e8f33dfa741bae292.tar.gz
mtk-20170518-f32d3bc30e83079d353fe72e8f33dfa741bae292.tar.bz2
Add kmod-nfs package
SVN-Revision: 360
Diffstat (limited to 'openwrt/package/linux')
-rw-r--r--openwrt/package/linux/Config.in7
-rw-r--r--openwrt/package/linux/Makefile5
-rw-r--r--openwrt/package/linux/control/kmod-nfs.control8
3 files changed, 20 insertions, 0 deletions
diff --git a/openwrt/package/linux/Config.in b/openwrt/package/linux/Config.in
index 81cf74b..bcb73db 100644
--- a/openwrt/package/linux/Config.in
+++ b/openwrt/package/linux/Config.in
@@ -29,6 +29,13 @@ config BR2_PACKAGE_KMOD_IPT6
help
IPv6 firewalling support
+config BR2_PACKAGE_KMOD_NFS
+ tristate "NFS support"
+ default m
+ help
+ Kernel modules for NFS support
+ Includes lockd, nfs and sunrpc
+
config BR2_PACKAGE_KMOD_USB
tristate "USB/SCSI support"
default m
diff --git a/openwrt/package/linux/Makefile b/openwrt/package/linux/Makefile
index 5909493..c6c270b 100644
--- a/openwrt/package/linux/Makefile
+++ b/openwrt/package/linux/Makefile
@@ -40,6 +40,11 @@ $(eval $(call KMOD_template,IPT6,ip6tables,\
$(eval $(call KMOD_template,IPV6,ipv6,\
$(MODULES_DIR)/kernel/net/ipv6/ipv6.o \
))
+$(eval $(call KMOD_template,NFS,nfs,\
+ $(MODULES_DIR)/kernel/fs/lockd/*.o \
+ $(MODULES_DIR)/kernel/fs/nfs/*.o \
+ $(MODULES_DIR)/kernel/net/sunrpc/*.o \
+))
$(eval $(call KMOD_template,USB,usb,\
$(MODULES_DIR)/kernel/drivers/scsi/*.o \
$(MODULES_DIR)/kernel/drivers/usb/*.o \
diff --git a/openwrt/package/linux/control/kmod-nfs.control b/openwrt/package/linux/control/kmod-nfs.control
new file mode 100644
index 0000000..9d38c31
--- /dev/null
+++ b/openwrt/package/linux/control/kmod-nfs.control
@@ -0,0 +1,8 @@
+Package: kmod-nfs
+Priority: optional
+Section: sys
+Version: 2.4.29-1
+Architecture: mipsel
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Kernel modules for NFS support