summaryrefslogtreecommitdiff
path: root/openwrt/package/lua
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 12:12:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 12:12:59 +0000
commit6b758a5dc3bc19877e9c3eefc12ce04d7041334f (patch)
tree4478a1a9bc90bda0dab2c84fce154218f3e11aae /openwrt/package/lua
parent9ae81d33764adae7a2a68cd54087bc5a9c68a181 (diff)
downloadmtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.zip
mtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.tar.gz
mtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.tar.bz2
lots of small package changes and dependency cleanups for the V= stuff
SVN-Revision: 2230
Diffstat (limited to 'openwrt/package/lua')
-rw-r--r--openwrt/package/lua/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/lua/Makefile b/openwrt/package/lua/Makefile
index 95f5fec..4b062de 100644
--- a/openwrt/package/lua/Makefile
+++ b/openwrt/package/lua/Makefile
@@ -27,7 +27,7 @@ $(eval $(call PKG_template,LUA_EXAMPLES,lua-examples,$(PKG_VERSION)-$(PKG_RELEAS
$(PKG_BUILD_DIR)/.configured:
touch $@
-$(PKG_BUILD_DIR)/.built:
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CROSS)gcc" \
LD="$(TARGET_CROSS)ld" \
@@ -96,5 +96,5 @@ uninstall-dev:
$(STAGING_DIR)/usr/include/lauxlib.h \
$(STAGING_DIR)/usr/lib/liblua{,lib}.{a,so*} \
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev